virtual-less 0.0.1a

Install lessc into your virtualenv

This is a small package that installs the less compiler for CSS into you virtual environment without the need of a global installation or the node package manager. The package is based on python-less and currently only installs the latest version of less.

This package does not include node.js and does not specify it as a requirement to be as flexible as possible. If you would like a similarly easy installation of node into your virtualenv you can check out virtual-node.

Installation

Installing the lessc commandline compiler is as easy as:

$ pip install virtual-less

that should be it. You should now be able to run the less compiler in you shell. You can check where lessc is installed to confirm that:

$ which lessc
/home/elbaschid/.virtualenvs/lessc-test/bin/lessc

Issues & Contributions

Please let me know if you have any issues, please raise an issue here on the github project.

If you want to contribute, fork this repository and open a pull request with your changes. I'd be happy to include them.

License

Oscar is released under the permissive New BSD license.

BSD

Author

Sebastian Vetter

Pip

virtual-less==0.0.1a

Classifiers

  • Topic :: Software Development :: Libraries
  • Programming Language :: JavaScript
  • Operating System :: POSIX
  • License :: OSI Approved :: BSD License
  • Intended Audience :: Developers
  • Environment :: Web Environment
  • Environment :: Console
  • Development Status :: 3 - Alpha
File Type Python Version Uploaded On Downloads
virtual-less-0.0.1a.tar.gz Source Oct. 15, 2012 1,578
Version Release Date
0.0.1a Oct. 15, 2012
0.0.1-1.3.3 Jan. 20, 2013
Date Package Version Action
Feb. 2, 2015, 5:24 a.m. virtual-less 0.0.1-1.3.3 Release Created
Feb. 2, 2015, 5:24 a.m. virtual-less 0.0.1a Release Created
Feb. 2, 2015, 5:24 a.m. virtual-less Package Created