Version 2.1.7

Released on 2017/09/14.

Note

If you are upgrading a cluster, you must be running CrateDB Version 1.1.3 or higher before you upgrade to 2.1.7.

If you want to perform a rolling upgrade, your current CrateDB version number must be Version 2.1.0. If you want to upgrade from a version prior to this, the upgrade will introduce all of the breaking changes listed for Version 2.1.0, and will require a full restart upgrade.

Consult the upgrade notes for Version 2.1.0 when upgrading.

Warning

Before upgrading, you should back up your data.

Table of contents

Changelog

Fixes

  • Fixed an issue causing global aggregations with JOINs on virtual tables (sub-selects) which contain LIMIT to return incorrect results. E.g.:

    SELECT COUNT(*) FROM
      (SELECT * FROM t1 ORDER BY a LIMIT 5) t1,
    JOIN
      t2
    ON t1.a = t2.b
    
  • Fixed an issue that caused an error when trying to create a table with a generated column expression of type array.

  • Fixed an issue that caused the account_user-column to be empty in the twitter tutorial plugin of the Admin UI.

  • Fixed an issue when using GRANT/REVOKE/DENY statements on a table with a custom schema set. The statements would result in permission changed on the default doc schema.

  • Fixed an issue with INNER and CROSS JOINS on more than 2 tables that could result in a Iterator is not on a row error.