Version 2.1.6

Released on 2017/08/29.

Note

If you are upgrading a cluster, you must be running CrateDB Version 1.1.3 or higher before you upgrade to 2.1.6.

If you want to perform a rolling upgrade, your current CrateDB version number must be Version 2.1.0. If you want to upgrade from a version prior to this, the upgrade will introduce all of the breaking changes listed for Version 2.1.0, and will require a full restart upgrade.

Consult the upgrade notes for Version 2.1.0 when upgrading.

Warning

Before upgrading, you should back up your data.

Table of contents

Changelog

Fixes

  • Fixed issue that caused the Monitoring tab to redirect to /401 when the user didn’t have privileges for sys.cluster or sys.jobs_log.

  • Fix issue where a DROP TABLE statement would return before the table privileges are dropped.

  • Fixed a bug which returned a malformed response for PSQL queries containing whitespace characters.

  • Fixed a bug in the detection of correlated subqueries which are currently unsupported.

  • Fix display of redundant parenthesis around expressions visible in SHOW CREATE and EXPLAIN statements.

  • Updated Crash to 0.21.5 which removes a deprecation warning logged in CrateDB server on every REST request.

  • Fixed an issue that caused path.logs setting in crate.yml to be ignored.

  • Fixed column name in output by removing new lines when select list contains subquery. E.g.:

    SELECT 1 =
        (SELECT 1)
    
  • Fixed an issue that prevents CrateDB from bootstrap on Windows hosts.

  • Fixed an issue that caused queries with IS NULL or IS NOT NULL on columns of type geo_point to fail.

  • Changed crate unix/linux startup script to use standard sh syntax instead of bash specific syntax.